Yaml for 0.8 version does not work with 1.0 due to duplicate key names

#1

Hi! I have just updated my drone instance from 0.8 version to 1.0 version and my yaml did not work out-of-the-box. I had an error: “linter: duplicate step names”. I found that my yaml had two steps with exactly the same name, but with 0.8 version everything was fine.

0 Likes

#2

while it is true this used to work with 0.8, it will not work with 1.0 because the yaml specification does not allow duplicate key names, and 1.0 more strictly follows the specification.

The content of a mapping node is an unordered set of key: value node pairs , with the restriction that each of the keys is unique.

Also in 1.0 the step names are a unique key in the database. So even if we eased up this restriction in yaml parsing, it would still cause a database error. Therefore the 0.8 yaml will need to be slightly adjusted to use unique names with 1.0.

0 Likes