Trusted repos in rc.5


#1

I feel a bit dumb right now.

I don’t find the “Trusted” checkbox on the rc.5 UI.

The CLI says it does the job, without actually flipping the flag

➜  DRONE_SERVER=xxx DRONE_TOKEN=$DRONE_TOKEN_V1 ./drone repo update xxx --trusted=true                         
Successfully updated repository xxx
➜  DRONE_SERVER=xxxx DRONE_TOKEN=$DRONE_TOKEN_V1 ./drone repo info xxx                                          
Owner: karnov
Repo: xxx
Config: .drone.v1.yml
Visibility: internal
Private: true
Trusted: false
Protected: false
Remote: xxx

The API returns 200, but the flag is not set

curl -i -X PATCH https://xxx/api/repos/yyyy/zzzz -H "Authorization: Bearer $DRONE_TOKEN_V1" --data '{"trusted": true}'

HTTP/2 200 
cache-control: no-cache, no-store, must-revalidate, private, max-age=0
content-type: application/json
expires: Thu, 01 Jan 1970 00:00:00 UTC
pragma: no-cache
vary: Origin
x-accel-expires: 0
content-length: 562
date: Fri, 08 Feb 2019 11:26:59 GMT

{"id":1,"uid":"161178448","user_id":1,"namespace":"zzz","name":"xxx","slug":"eee","scm":"","git_http_url":"ccc","git_ssh_url":"vvv","link":"999","default_branch":"master","private":true,"visibility":"internal","active":true,"config_path":".drone.v1.yml","trusted":false,"protected":false,"timeout":60,"counter":22,"synced":1549548287,"created":1549548287,"updated":1549548287,"version":51}

Is it me or Drone? :slight_smile:


#2

only a drone system admin can see the trusted checkbox. see https://docs.drone.io/administration/user/admins/


#3

doh, my colleague set this instance up. I’m not used to not being admin :slight_smile:

I’ll try shortly.


#4

Works. This is actually something know in 1.0 i wasn’t aware. Thanks for help.