Stuck in pending status

I suddenly cannot build anything in drone. All attempts leave me with a build stuck in “pending”. From chrome devtools I’m seeing the following errors:

TypeError: Cannot read property 'slug' of undefined
    at a.hrefCommit (app.c487a027.js:1)
    at sn.get (chunk-vendors.f5840117.js:7)
    at sn.evaluate (chunk-vendors.f5840117.js:7)
    at a.hrefCommit (chunk-vendors.f5840117.js:7)
    at a.config (app.c487a027.js:1)
    at sn.get (chunk-vendors.f5840117.js:7)
    at sn.evaluate (chunk-vendors.f5840117.js:7)
    at a.config (chunk-vendors.f5840117.js:7)
    at a.Te (app.c487a027.js:1)
    at a.t._render (chunk-vendors.f5840117.js:7)

If I expand the app.js it seems to be tripping up at:

hrefCommit: function() {
    return "/link/".concat(this.repo.slug, "/commit/").concat(this.build.after)
},

which suggests that this.repo does not exist. :thinking:

Any one have any ideas?

I suddenly cannot build anything in drone.

a javascript error in the UI cannot prevent a build from running in the backend. Do you mean to report that the UI is not properly rendering the page or is not properly rendering live updates?

I doubt it prevents the build from happening but the UI is stuck in pending forever.

10

I looked in the docker container logs but all I see is:

{"level":"info","msg":"main: internal scheduler enabled","time":"2019-09-26T11:00:47Z"}
{"level":"info","msg":"main: internal scheduler enabled","time":"2019-09-26T11:00:47Z"}
{"acme":false,"host":"drone.example.com","level":"info","msg":"starting the http server","port":":80","proto":"https","time":"2019-09-26T11:00:47Z","url":"https://drone.example.com"}
{"interval":"30m0s","level":"info","msg":"starting the cron scheduler","time":"2019-09-26T11:00:47Z"}

I’m guessing I need to enable verbose logging somewhere to get more info?

See Builds are Stuck in Pending Status

Also did you download directly from master (e.g. drone/drone:latest)? If yes, please note there is a breaking configuration change to single machine mode. I recommend using the 1.4 tagged release instead.

Yeah, so I’m using watchtower, it was due to breaking changes in latest. Have rolled back for now as suggested. Really appreciate the assistance, thanks. :+1:

Great, glad that helped resolve the issue.

I can provide some more context regarding the change in master …

Previously the server was started in single machine mode with agents disabled by default. In :latest the server is started with agents enabled by default. So if you want to run in single machine mode with :latest you need to explicitly disable agents with DRONE_AGENTS_DISABLED=true

Thanks for the explanation but I think it’s probably best I stick to versions over latest. :smiley: