[SOLVED]Drone compatitable with gitlab v3 api

Drone have upgrade to gitlab api v4 long ago


Can we compatitable with gitlab v3 api with some configure? just because my company is using Gitlab 8 and it seems no update plan in short time.

OK, I find a environment DRONE_GITLAB_V3_API which not mention in doc can set drone use v3 api in drone 0.8.

so does the config still exist in drone 1.0 @bradrydzewski ? sorry I can’t see source code for 1.0 so I can’t check this question by myself. I have tried to use GITLAB_V3_API and GITLAB_CLIENT_V3_API, both doesn’t work.

It seems gitlab v3 api have removed from 1.0 version. And pluggable driver feature will support in the future. I’d like waiting for it.

https://github.com/drone/go-scm/issues/4