Drone

Plugin peloton/drone-ecs deploy fail

We just migrate drone 0.8 to 1.0.
And during building process, we met an error(figure below).

But I cant find more information about those parameters in drone ecs document.
Could I get some suggestions to trace/correct this error?

can you provide more details, like a copy of your yaml?

This is a part of my .drone.yml, also the failed part.
Hope these would be helpful, thank you.

  deployDevProxy:
    image: peloton/drone-ecs
    region: ap-northeast-1
    service: ****-frontend-dev
    container_name: ****-frontend-proxy
    family: ****-frontend-dev
    cluster: ****-ECS-dev
    task_role_arn: ****-frontend-task-role
    docker_image: ********.dkr.ecr.ap-northeast-1.amazonaws.com/****-frontend
    tag: develop
    environment_variables:
      - NODE_ENV=development
      - API_ENDPOINT=https://****/api
      - BUILD_TAG=${DRONE_BRANCH}-${DRONE_BUILD_NUMBER}
    cpu: 256
    memory: 256
    desired_count: 1
    deployment_configuration:
      - 50 200
    log_driver: awslogs
    log_options:
      - awslogs-group=****-frontend
      - awslogs-region=ap-northeast-1
      - awslogs-stream-prefix=/dev
    port_mappings:
      - 0 8080
    when:
      branch: [develop]

I’ve adjusted the title of this thread from drone/ecs to peleton/drone-ecs since these are different plugins. I am the author of drone/ecs but am not the author of peleton/drone-ecs, which is a third party plugin. I therefore recommend opening an issue with the plugin author to get assistance.

Okay, I misunderstood.
I’ll try it, thank you.:slightly_smiling_face: