Drone

Network_mode: service:name

Hello,

In order to access to another build environment via ssh, I set up an openvpn service client (dperson openvpn-client).

Except in order for it to work you need to share the service’s network stack (done with –net=container:vpn in a standard docker command).

I’ve understood I should use network_mode field and set it up to service:openvpn (openvpn is the name of my service) but I keep getting the error : Error response from daemon: network service:openvpn not found when testing with drone.

Any insight ?

Many thanks !

1 Like

I would love to use this feature too. Besides vpn, i need to use custom dns whose record can be manipulate in the test. Using the custom dns as service and then specifying the test step to use the custom dns container’s network plus dns: 127.0.0.1 setting will made this possible