Drone

Migration of drone from drone-runtime to drone-runners

The main drone codebase currently relies on drone/drone-runtime, which is deprecated in favor of the various drone-runners repositories. Are there plans/is there work underway to update drone to use the new runners?

Hi Erin,

The code that uses the drone/drone-runtime package was deprecated and will be removed in the future. The official installation instructions were updated accordingly to help you install the new runners, which do not rely on this package.

Thanks, Ash. Is there an issue I can keep an eye on to stay abreast of the progress on removing the drone-runtime dependencies from the drone internals?

this is not something we are actively tracking since there are no immediate plans to remove the deprecated feature. Practically speaking it should not impact most of our users. When we do remove the capability we will release a new major version of Drone (e.g. 2.0.0) to signify the change.