Migrating to 1.0.0-rc-3, gopath/vendored imports missing


#1

In the old .drone.yaml, workspaces were defined with a base path and a src path. My builds are failing in 1.0.0-rc-3 because it can’t find referenced go imports that are in /vendor of my repository. Is there a setting I’m missing (read through the docs?) or am I supposed to set the GOPATH manually in the build step?


#2

1.0 still uses workspaces. Here is an example 1.0 yaml syntax for a Go project


#3

As usual, thanks for the quick answer! I figured this was still the case but wasn’t sure at what hierarchy level the field would be in the new yaml scheme. I’m sure you’ve got this stuff planned for docs when time permits. Keep up the great work!