Drone

Kube runner long command can't run

Hi,

I am running kube runner and it seems if there is multiple command on steps with long line the drone can’t run it:
- name: api-integration-tests
pull: if-not-exists
image: docker
commands:
- docker run -d -p 8040:8040 -e SHADOW_CONF=./config/config.json --name api-run --network=local-net sit-svc-data-collector:build uwsgi --ini ./ops/etc/uwsgi.ini --http :8040 --workers 1
- docker run -i -t=false --network=local-net sit-svc-data-collector:build ping api-run -c1
- docker run -i -t=false -e TEST_SERVER_URL=http://api-run:8040 --network=local-net sit-svc-data-collector:build pytest -vvv -s tests/integration/collector/api
volumes:
- name: dockersock
path: /var/run

  • docker run -i -t=false -e TEST_SERVER_URL=http://api-run:8040 --network=local-net sit-svc-data-collector:build pytest -vvv -s tests/integration/collector/api
    14 “docker run” requires at least 1 argument.
    15 See ‘docker run --help’.
    16
    17 Usage: docker run [OPTIONS] IMAGE [COMMAND] [ARG…]
    18
    19 Run a command in a new container
    20

This is the error but the command has exactly what its need.

maybe it is an issue with yaml escaping a character? perhaps to to use block scalaras to avoid escaping issues?

commands:
- |
    docker run -d -p 8040:8040 -e SHADOW_CONF=./config/config.json --name api-run --network=local-net sit-svc-data-collector:build uwsgi --ini ./ops/etc/uwsgi.ini --http :8040 --workers 1
- |
    docker run -i -t=false --network=local-net sit-svc-data-collector:build ping api-run -c1
- |
    docker run -i -t=false -e TEST_SERVER_URL=http://api-run:8040 --network=local-net sit-svc-data-collector:build pytest -vvv -s tests/integration/collector/api