Is it safe to upgrade from Drone 1 to Drone 2?

Anything I should be aware of?

It looks like the versions got bumped inside the Docs, so I was thinking of upgrading my instance to follow suit.

1 Like

Hello, @hwittenborn !

I’ve upgraded my Drone installation from 0.8 to 1.0 and then to 2.0. All worked fine but one thing: old builds (made in 0.8) were not available in 2.0. If you didn’t upgrade from 0.8 all should be O’K.

UPD: If you need, I can share a script for reenumerating old (0.8) builds to be seen in recent (2.0) versions of Drone.

2 Likes

Are there any breaking changes while upgrading from 1.x to 2.x that you came across?

I didn’t get any issues on my end - all I did was update the image version, and then everything just kept on working like normal.

2 Likes

Worked flawlessly for me as well.

1 Like