Drone

Helm Stable Chart Deprecated

The charts in Helm Stable have been formally deprecated in favor of our official charts.

If you installed Drone using Helm Stable with the below flag enabled (which was the default) you have been using an experimental Kubernetes integration that was deprecated almost a year ago :frowning: and has been unmaintained since.

server.kubernetes.enabled=true

The experimental kubernetes integration was deprecated in favor of the new Kubernetes Runner. The Kubernetes Runner is a separate runner that needs to be installed alongside the Drone server to schedule pipelines on Kubernetes. You should not assume things with just work when you make the switch. You will need to make the following changes:

  1. You need to unset DRONE_KUBERNETES_ENABLED to ensure the deprecated functionality is no longer enabled.
  2. You need to update your pipelines to use type: kubernetes. See https://docs.drone.io/pipeline/kubernetes/overview/

If you have issues please consult our official installation guide and our configuration reference. Also please search this forum for existing threads related to upgrading to the new Kubernetes Runner.

1 Like