Drone

Helm - env: DRONE_RPC_SECRET is required

I am trying to install drone using the helm charts provided,
I put DRONE_RPC_SECRET as Kuberenets secrets and put the value here:
extraSecretNamesForEnvFrom:

  • drone-server-secrets-XXXX

but when I am using --install I am getting the following error:
Error: values don’t meet the specifications of the schema(s) in the following chart(s):
drone:

  • env: DRONE_RPC_SECRET is required

when I do template --show-only
envFrom:
- configMapRef:
name: XXX-drone
- secretRef:
name: drone-server-secrets-XXXX

it seems that is doesn’t know how to get it when using template although this secret appear in this DATA, it should be fixed because I don’t want to save this secret on github

@bradrydzewski any update regarding this? this is security risk