Enable TLS between drone server and k8s runner fails

Hi, we deployed drone server and k8s runner via helm.
Drone server is behind nginx load balancer equipped with managed certificate (ACM).

We would like to enable encryption between drone server and runner as well.

I already created a tls secret.

from the k8s runner helm chart:

ingress:
  enabled: true
#  annotations:
#    kubernetes.io/ingress.class: nginx
  hosts:
    - host: myhost.com
      paths:
        - "/"
  tls:
    - secretName: k8s-runner-tls-secret
      hosts:
      - myhost.com

I’m getting this error when I switch the enabled: true:

Error: UPGRADE FAILED: error validating "": error validating data: [ValidationError(Ingress.spec.rules[0].http.paths[0].backend): unknown field "serviceName" in io.k8s.api.networking.v1.IngressBackend, ValidationError(Ingress.spec.rules[0].http.paths[0].backend): unknown field "servicePort" in io.k8s.api.networking.v1.IngressBackend]

Is it a known issue with the chart?

Thanks in advance,
Erez