Deployment: Error response from daemon: client version 1.40 is too new. Maximum supported API version is 1.39

Hi all,

running latest drone docker an a Synology NAS. On my latest deployment I am receiving the following error message:

deployment: Error response from daemon: client version 1.40 is too new. Maximum supported API version is 1.39

docker version gives:

Client:
 Version:           18.09.8
 API version:       1.39
 Go version:        go1.11
 Git commit:        bfed4f5
 Built:             Fri Mar 13 06:46:11 2020
 OS/Arch:           linux/amd64
 Experimental:      false

Server:
 Engine:
  Version:          18.09.8
  API version:      1.39 (minimum version 1.12)
  Go version:       go1.11
  Git commit:       3a371f3
  Built:            Fri Mar 13 06:44:35 2020
  OS/Arch:          linux/amd64
  Experimental:     false

Is there any chance to put a DOCKER_API_VERSION (https://docs.docker.com/engine/reference/commandline/cli/#environment-variables) somewhere to get it work?

Thanks for your help :slight_smile:

You can use any DOCKER_ variables with Drone, no code changes needed. Drone uses the official Go client for Docker which automatically reads all DOCKER_ variables. This variable should be passed to the runner, which is where the Docker client code exists.

Awesome - works perfect! Thanks for your quick reply :+1: