Debugging with tmate and autoscaler (ec2)

Whenever I try to debug a failed pipeline on a drone system with aws autoscaler it fails with

	/bin/sh: /usr/drone/bin/tmate: not found

I can’t set DRONE_TMATE_ENABLED=true as I don’t know how/where to set this as i don’t have the drone-docker-runner setup manually, because these are instantiated through the autoscaler but the autoscaler doesn’t seam to have a setting like DRONE_TMATE_ENABLED.

Any suggestions what am I doing/thinking wrong? Thx.

I’m having the same problem using debug in Drone builds with the only step exit 78.

Here is my .drone.yml:

---
kind: pipeline
type: docker
name: default

platform:
  os: linux
  arch: amd64

clone:
  disable: true

steps:
- name: exit
  image: registry.cartesius.local/git:latest
  commands:
  - exit 78
...

DRONE_TMATE_ENABLED=true is not set in my configuration, drone and drone-runner-docker are latest versions.

As an addition to this, when the step is running I observe this log

and then, after build finishes, this log

@bradrydzewski, any thoughts?

I changed line

image: drone/drone-runner-docker:1

to this

image: drone/drone-runner-docker:latest

and the problem was gone.