Drone

Backward compatibility with older versions of Stash was broken in drone 1.x.x

I have pretty old Atlassian Stash 4.3.3 + Web Post Hooks for Bitbucket Server 3.1.0 and Drone 0.5.x
When switching to drone version 1.x.x broke compatibility with older versions of Stash.
Stash 4.3.3 REST API have no webhooks just hooks. Webhooks appear in newer versions of Stash.

I think that backward compatibility was broken after discussions in this thread.

Is it possible to create an environment variable (Ex: DRONE_STASH_VERSION) that will be responsible for the generation of stash and will regulate the use of hooks or webhooks?