Autoscaler agent labels do not work as documented

When DRONE_AGENT_LABELS env variable is set like documentation says:
https://autoscale.drone.io/reference/drone-agent-labels/

Autoscaler does not schedule servers at all. When I manually run command

drone server create

it starts a server and runs proper pipeline with exact labels I configured in pipeline definition.

Is anyone tried autoscaler with runner labels?

Hi @Roman_Navrotskii,

Can you please help us out with the following:

  1. Are you trying to autoscale the servers and these labels dont show correctly? you can refer to Autoscaling with Labels?
  2. While you create a server manually are the labels still incorrect?
    If possible can you please share your configuration to see how you are using the DRONE_AGENT_LABELS?

Thank you

Hi @csgit

Thanks for your answer!

Yes, I try to scale servers by labels. In pipeline definition I added

node:
  somelabel: somelabelvalue

And on autoscaler configuration I have environment variable

DRONE_AGENT_LABELS=somelabel:somelabelvalue

So I believe that autoscaler should schedules only servers for pipelines with that label.

When I create server manually all labels passed to RUNNER correctly.

Actually I just need an amd64 and arm64 builds. I use 2 autoscalers with different runner configuration (instance type, image, min, max). Both autoscalers connected to the single drone server.

The problem is when I am trying to use labels, it ignores pipelines with that labels (and ignores all pipelines as well).

I am curious why do we need parameter DRONE_AGENT_LABELS at all?

@csgit

Am I use DRONE_AGENT_LABELS properly? Or maybe I misunderstood something?