Activate Github Repository: Validation failed


#1

Running 1.0.0-rc5, with Kubernetes and Github

I see the list of all my repositories, but I can’t activate any. For me or an organization.

{"level":"debug","msg":"api: root access granted","name":"my-repo","namespace":"my-org","request-id":"1GqGYM1c9rLXSqpRWHmiwtDJyfr","time":"2019-02-07T07:49:21Z","user.admin":true,"user.login":"bclermont"}
{"level":"debug","msg":"api: root access granted","name":"my-repo","namespace":"my-org","request-id":"1GqGYM1c9rLXSqpRWHmiwtDJyfr","time":"2019-02-07T07:49:21Z","user.admin":true,"user.login":"bclermont"}
{"fields.time":"2019-02-07T07:49:21Z","latency":1272565,"level":"debug","method":"GET","msg":"","remote":"10.44.7.74:36422","request":"/api/repos/my-org/my-repo/secrets","request-id":"1GqGYM1c9rLXSqpRWHmiwtDJyfr","time":"2019-02-07T07:49:21Z"}
{"level":"debug","msg":"api: root access granted","name":"my-repo","namespace":"my-org","request-id":"1GqGYJjQGsjnmZBTgMYjUBBScAs","time":"2019-02-07T07:49:21Z","user.admin":true,"user.login":"bclermont"}
{"level":"debug","msg":"api: root access granted","name":"my-repo","namespace":"my-org","request-id":"1GqGYJjQGsjnmZBTgMYjUBBScAs","time":"2019-02-07T07:49:21Z","user.admin":true,"user.login":"bclermont"}
{"level":"debug","msg":"api: root access granted","name":"my-repo","namespace":"my-repo","request-id":"1GqGYOYYqAcWgi0SsW1iACFOl7f","time":"2019-02-07T07:49:21Z","user.admin":true,"user.login":"bclermont"}
{"fields.time":"2019-02-07T07:49:21Z","latency":1436835,"level":"debug","method":"GET","msg":"","remote":"10.44.7.74:36422","request":"/api/repos/my-org/my-repo","request-id":"1GqGYOYYqAcWgi0SsW1iACFOl7f","time":"2019-02-07T07:49:21Z"}
{"fields.time":"2019-02-07T07:49:21Z","latency":680516,"level":"debug","method":"GET","msg":"","remote":"10.44.7.74:36466","request":"/api/repos/my-org/my-repo/cron","request-id":"1GqGYJjQGsjnmZBTgMYjUBBScAs","time":"2019-02-07T07:49:21Z"}
{"level":"debug","msg":"api: root access granted","name":"my-repo","namespace":"my-org","request-id":"1GqGYgEFoHBIs0Twh4ZtHVI5dPm","time":"2019-02-07T07:49:23Z","user.admin":true,"user.login":"bclermont"}
{"level":"debug","msg":"api: root access granted","name":"my-repo","namespace":"my-org","request-id":"1GqGYgEFoHBIs0Twh4ZtHVI5dPm","time":"2019-02-07T07:49:23Z","user.admin":true,"user.login":"bclermont"}
{"error":"Validation Failed","level":"debug","msg":"api: cannot create or update hook","name":"my-repo","namespace":"my-org","request-id":"1GqGYgEFoHBIs0Twh4ZtHVI5dPm","time":"2019-02-07T07:49:23Z","user.admin":true,"user.login":"bclermont"}
{"fields.time":"2019-02-07T07:49:23Z","latency":596786204,"level":"debug","method":"POST","msg":"","remote":"10.44.7.74:36466","request":"/api/repos/my-org/my-repo","request-id":"1GqGYgEFoHBIs0Twh4ZtHVI5dPm","time":"2019-02-07T07:49:23Z"}
{"fields.time":"2019-02-07T07:49:27Z","latency":15103,"level":"debug","method":"GET","msg":"","remote":"10.44.7.1:40790","request":"/","request-id":"1GqGZ48lB3sHxw07JiLHow121GK","time":"2019-02-07T07:49:27Z"}

It’s very unclear what validation failed is… what is validated?

I can’t find the source code of 1.0, I can’t troubleshoot any issues anymore.

I removed all previous web-hooks for 0.8… just in case, same problem


#2

good question, that error message comes from GitHub, so you would have to ask them :slight_smile: My guess is that perhaps your DRONE_SERVER_HOST or DRONE_SERVER_PROTO settings are missing or malformed, resulting in an invalid webhook url, but tough to say.


#3

good question, that error message comes from GitHub, so you would have to ask them

I could have figured that if I had access to the source code

settings are missing or malformed, resulting in an invalid webhook url, but tough to say.

If I had access to source code, I could create a PR that log the webhook URL before it call github API, for that kind of troubleshooting


#4

I fixed the host value in helm chart and it’s working now