Acme/autocert: missing server name on EC2 Ubuntu 18.04


#1

This post was flagged by the community and is temporarily hidden.


#2

The variable names in your snippet are incorrect:

-DRONE_HOST=mydomain.com
-DRONE_HOST_PROTOCOL=https
+DRONE_SERVER_HOST=mydomain.com
+DRONE_SERVER_PROTO=https

also if you are just now installing drone, you should be using rc.6. Did you follow the official installation instructions at docs.drone.io?


#3

This post was flagged by the community and is temporarily hidden.


#4

a permanent redirect loop would usually indicate something is misconfigured with your github oauth redirect url. There are other reasons this can happen (reverse proxy issues, etc) but it is the most common issue we see people have. Have you looked at your Drone server logs with debug mode enabled to try and get more details? Have you confirmed your redirect URL exactly matches the scheme, hostname and path that is required? Can you provide more details (logs ,screenshot of github application configuration, drone server configuration) so we can see the full picture?


#5

What I am running:

docker run --volume=/var/run/docker.sock:/var/run/docker.sock --volume=/var/lib/drone:/data --env=DRONE_GITHUB_SERVER=https://github.com --env=DRONE_GITHUB_CLIENT_ID=123 --env=DRONE_GITHUB_CLIENT_SECRET=abc --env=DRONE_RUNNER_CAPACITY=2 --env=DRONE_SERVER_HOST=drone.url.com --env=DRONE_SERVER_PROTO=https --publish=80:80 --publish=443:443 --restart=always --detach=true --name=drone-testy --env=DRONE_TLS_AUTOCERT=true drone/drone:1.0.0-rc.1

Github OAuth app settings

Client ID: 123
Client Secret: abc
Authorization callback URL - https://drone.url.com

When I go to my domain I see the GitHub OAuth screen and I click to authorize my app. It then continually redirects to URLs (with params like ?code=2c353334adacdb60c1ae&state=c2ea3b9393f93f33) until I get a notice from GitHub that I need to reauthorize the app due to too many requests and then it goes back to switching between several URLs like the above

Log output from docker logs -f with debug mode enabled on the server

{"level":"info","msg":"main: starting the local build runner","threads":2,"time":"2019-03-12T16:23:56Z"}
{"acme":true,"host":"drone.url.com","level":"info","msg":"main: starting the http server","port":":443","proto":"https","time":"2019-03-12T16:23:56Z","url":"https://drone.url.com"}
{"interval":1800000000000,"level":"info","msg":"main: cron schedule disabled","time":"2019-03-12T16:23:56Z"}

#6

the authorization callback URL looks like it is missing the path:

Client ID: 123
Client Secret: abc
-Authorization callback URL - https://drone.url.com
+Authorization callback URL - https://drone.url.com/login

#7

Ah!! IT WORKS. Thanks so much.